Has XLWDotNet been upgraded to vs2013 yet?

For discussion of the xlw project for producing xlls.

Has XLWDotNet been upgraded to vs2013 yet?

Postby ronnie95 » Sun Nov 09, 2014 7:13 pm

I'm getting a lot of errors when trying to compile the autogenerated files in the sample template.


1> ClCompile:
1> H:\Apps\Visual Studio\VC\bin\x86_amd64\CL.exe /c /I"H:\apps\xlw-5.0.1f0/xlw/include" /I"H:\apps\xlw-5.0.1f0\xlwDotNet/xlwDotNet" /Zi /nologo /W3 /WX- /Od /D WIN32 /D _DEBUG /D _WINDOWS /D _USRDLL /D EXAMPLEXLL_EXPORTS /D _WINDLL /D _UNICODE /D UNICODE /Gm- /EHa /MDd /GS /fp:precise /Zc:wchar_t /Zc:forScope /Fo"H:\Users\Mushfaque.Cradle\Documents\XLL_Project\Addin\../x64_Debug\obj\\" /Fd"H:\Users\Mushfaque.Cradle\Documents\XLL_Project\x64_Debug\Template.pdb" /TP /FU"H:\apps\xlw-5.0.1f0\xlwDotNet/lib/x64/xlwDotNet-vc110-mt-gd-5_0_1f0.dll" /FUH:\Users\Mushfaque.Cradle\Documents\XLL_Project\Addin\../x64_Debug\Template.NET.dll /errorReport:queue ..\AutoGeneratedSource\xlwXLL.cpp
1> xlwXLL.cpp
1> H:\Apps\Visual Studio\VC\bin\x86_amd64\CL.exe /c /I"H:\apps\xlw-5.0.1f0/xlw/include" /I"H:\apps\xlw-5.0.1f0\xlwDotNet/xlwDotNet" /AI"C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETFramework\v4.0" /AI"C:\Program Files (x86)\Windows Kits\8.1\References\CommonConfiguration\Neutral" /Zi /clr /nologo /W3 /WX- /Od /D WIN32 /D _DEBUG /D _WINDOWS /D _USRDLL /D EXAMPLEXLL_EXPORTS /D _WINDLL /D _UNICODE /D UNICODE /Gm- /EHa /MDd /GS /fp:precise /Zc:wchar_t /Zc:forScope /Fo"H:\Users\Mushfaque.Cradle\Documents\XLL_Project\Addin\../x64_Debug\obj\\" /Fd"H:\Users\Mushfaque.Cradle\Documents\XLL_Project\x64_Debug\Template.pdb" /TP /FU"H:\apps\xlw-5.0.1f0\xlwDotNet/lib/x64/xlwDotNet-vc110-mt-gd-5_0_1f0.dll" /FUH:\Users\Mushfaque.Cradle\Documents\XLL_Project\Addin\../x64_Debug\Template.NET.dll /FU"C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETFramework\v4.0\mscorlib.dll" /errorReport:queue /clr:nostdlib ..\AutoGeneratedSource\AssemblyFinder.cpp ..\AutoGeneratedSource\DLL.cpp
1> AssemblyFinder.cpp
1> DLL.cpp
1>H:\Apps\Visual Studio\VC\include\system_error(20): error C2869: 'std::errc' : has already been defined to be a namespace [H:\Users\Mushfaque.Cradle\Documents\XLL_Project\Addin\XLL.vcxproj]
1>H:\Apps\Visual Studio\VC\include\system_error(101): error C2146: syntax error : missing ';' before identifier 'generic_errno' [H:\Users\Mushfaque.Cradle\Documents\XLL_Project\Addin\XLL.vcxproj]
1>H:\Apps\Visual Studio\VC\include\system_error(101): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int [H:\Users\Mushfaque.Cradle\Documents\XLL_Project\Addin\XLL.vcxproj]
...

Looks like a namespace conflict between the CLR/c++ namespace. Any thoughts?
ronnie95
 
Posts: 1
Joined: Sun Nov 09, 2014 7:08 pm

Return to xlw

Who is online

Users browsing this forum: No registered users and 2 guests

cron